		    


Microsoft Access 2010
 Lab 4



In this practical you will learn how to create a customized form, how to use it to view data and add new records, and how to print it. You should first read the information given in this practical and then complete the activities listed throughout.




Create a Form with a Form Wizard

You can use a form to view and change your data in a layout other than the datasheet. In this section, we use a  Form Wizard to create a customized form and AutoForm to build simple forms automatically. Other Form Wizards provide a variety of layouts and styles for you to choose from.  They prompt you with questions about the form you want and then build the form based on your answers.  After using a Form Wizard to create your form, you can modify it if you want to.

1. Open the database. In the Database window, select the Create tab, then click the Form Wizard button. 

2.	Microsoft Access displays the New Form dialog box.

3.	Click on the down-arrow to select the table or query to provide the data for the form.

4.  Choose the Form Wizard option and then follow the instructions in the Form Wizard dialog boxes.

Note: If  you select any of the AutoForm options, a form is automatically created and opened for  you. The form shows the first record in the selected table.

[image: ]

Figure P4-1 Selecting tables and fields in Form Wizard


Use a Form to View Records

Now you have a form that you can use to view, change, add, and delete records in the selected table.  Examine the way Microsoft Access displays information on a form. The objects on the form are called controls which can be used to change the way you view your data. 

Microsoft Access places three kinds of controls on  a form. A form based on the Branch table of the DreamHome database created using the AutoForm (Columar) facility is shown in Figure P4-2. 


			[image: ]

Figure P4-2: Form based on Branch table in Form view.


A label displays text such as a title, caption, or message (e.g. street).

A text box provides an area where you can display or type text or numbers that are stored in your database.  Fields such as street and city of the Branch table are displayed in text boxes.

There are a variety of other controls you can add to Microsoft Access forms as well, including controls that display lists, contain pictures, or carry out actions.  

Microsoft Access forms provide three views of your data:  Form view, Layout view, and Design view.  Form view is often the best way to see all the fields in a single record at the same time, without scrolling.  You can use the toolbar to switch between the views.

To move from record to record on a form

Use the navigation buttons in the lower-left corner of the form’s window to go to the first, last, previous, or next record. You can also use the Go To command in the Home menu to move to the first, last, or next record or to a new record.




Activity P4-1

Open your DreamHome database. Add some sample rows (at least two) in the Branch table and in the Staff table (see examples below). Create a form for your Branch and Staff tables using the Form Wizard facility and name this form BranchView, with the list of staff named StaffList subform. Use the form to view records in your Branch table. Practice changing between viewing your Branch table using Form view and Layout view.
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Add and Save Records with a Form

To add a new record

1.  In Form view, from the Home menu, choose GoTo, and then choose New Record (or click the New button  at the bottom of the form and on the toolbar).  

											
     Microsoft Access displays the blank form at the end of the records. 

You can also use the Records menu and select New. However, in this mode you can only add and then view the newly appended records. 

2.  Enter data using TAB to move between fields.

To save a record

When you have completed the data entries for a record, press TAB to move to the next record.

As soon as you leave the record, Microsoft Access saves it in the table. If you want to save a record without leaving it, choose the Save command from the Records menu.

To undo your most recent change in a field before you leave the field


Click the Undo button on the toolbar.   

To delete a record

From the Records menu, click the Delete Record button.   


Activity P4-2

Use your form to view, change, add and delete records in your Branch table. Use the Undo Current Field/Record facility while editing your records.

 
Print, Save, and Close a Form

You can use Print Preview to see how your form will look in print before you print it.

To preview how a form and its data will look on a page

1. Choose Print Preview from the File menu (or choose the Print Preview button on the toolbar). Microsoft Access displays your form and its data as it will look in print.
												

2.  To zoom in on the page, position the pointer over the page so that it turns into a picture of a magnifying glass, and then click (or click the Zoom button on the toolbar).

											

3. To return to a view of the entire page, click the form again (or click the Zoom button again).
	
You can print your form from Print Preview or Form view.

To print a form

1.	From the File menu, choose Print (or click the Print      button on the toolbar). Microsoft Access only displays the Print dialog box when you select to print using the menu options.

To save a form

1.  From the File menu, choose Save. When a form is saved for the first time, Microsoft Access displays the Save As dialog box.

2.	Enter  the name of the form and then choose OK.
	
To save and rename a form, select the File menu and choose Save As.

To close a form

From the popup menu in the form, choose Close (or click the Control-menu box in the upper-right corner of the Form window).


Activity P4-3

First preview, and then print BranchView. 
 



Customizing Your Form

In this section, you will learn how to place, move, and resize controls on forms and how to display values in a list.  In addition, you will learn how to show a default value in a control so that the field has that value automatically for each new record.

Change a Form’s Design

You change the appearance of a form in the form’s Design view.  You can open your form in Design view from the Database window.

To open a form in Design view

1. In the Database window, select the name of the form.  (if necessary, click the Forms button to display the list of forms) and then click the Design  button. Microsoft Access opens the form in Design view.

Microsoft Access divides a form into five sections in Design view. A form based on the Branch table of the DreamHome database is shown in Figure P4-3. 

The form header prints at the top of the first page. When you are viewing data, the form header appears once at the top of the window.

The page header prints at the top of every  page (currently blank). The page header only appears when printed or in print preview.

The detail section contains the fields from the table.  When you are viewing data, the detail section is repeated for each record.  When you print the form, the detail section shows as many records as will fit on a page.

The page footer prints at the bottom of every  page (currently blank). The page footer only appears when printed or in  print preview.
The form footer prints at the bottom of every page (currently blank).  When you are viewing data, the footer appears once at the bottom of the window.

All forms have a detail section, but not all forms have a form/page header and footer.  To add these sections to a form, choose the Page Header/Footer command or Form Header/Footer from the popup menu.
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Figure P4-3:  Form based on Branch table in Design View.


Activity P4-4

Examine BranchView form in Design view. Ensure that you understand the purpose of the different sections of the form.
 



Select and Resize Controls

Controls are the objects on your form that display data from a field or words in a title.  In Design view, you can select, resize, move, and otherwise manipulate the controls on a form.

To select a control

Click the field’s text box.  (Make sure to click the text box and not its attached label.)
When you select a control, Microsoft Access displays size and move handles around the control.

Drag the handles on the top and bottom to size the text box vertically.
Drag the handles on the left and right sides to size the text box horizontally.
Drag the handles in the corners to size the text box both vertically and horizontally.
In controls with attached labels, use the move handles to move each part separately.
The size of the text box should be appropriate to the maximum length of the values to be displayed in the field.

To resize a control

1.	Position the pointer on the part of the border of the text box that is to be resized.
2.	Drag the border to shorten or lengthen the text box.  When the box is the size you want, release the mouse button.

You can also select more than one control at a time.  This is a convenient method for moving or aligning a group of controls.

To select more than one control

Position the pointer beside (not on) one of the controls you want to select, and then drag diagonally through all the controls you want to select. While you drag, Microsoft Access draws a rectangle around the controls.  When you release the mouse button, all the controls in or touching the rectangle are selected.  (You can also select a group of controls by holding down the SHIFT key while you click each control.)

Move Controls

All the text box controls on your form have attached labels.  You can move a control and its attached label together, or you can move them separately.  

To move a control

1.	If a control is selected but is not the one you wish to select, click outside the control to cancel the selection.
2.	Position the pointer anywhere on the selected control, and hold down the mouse button. The pointer changes to a hand symbol.
3.	Drag the control so that it is next to its text box. Note that Microsoft Access moves the text box and its attached label together.
4.	When the control is positioned where you want it, release the mouse button.

To lengthen a section

1. Position the pointer on the border between the detail section and the form footer.  
2. Drag the border down to lengthen the section.

Move Controls and Attached Labels Separately

When you move a text box, its attached label moves with it.  You can also move a control or its attached label separately.  To do that, you use the move handles. 

To move the attached label separately

1.	Select the control.
2.	Position the pointer over the label’s move handle. When the pointer is over the handle, it changes to a pointing hand.
3.	Drag the move handle to the required position.
4. When the label is where you want it, release the mouse button.

Add a Label and Edit Label Text

A label is a type of control you can place on your form to add information. A freestanding label is not bound to a field (like a text box) or attached to a control (like a text box’s label). The first time you open a form in Design view, Microsoft Access displays the toolbox. 

You use the toolbox to place new controls on your form. You can close or open the toolbox by choosing Toolbox from the View menu.  You can also move the toolbox on your screen by dragging its title bar.

More information  For details about each type of control, click the respective tool in the toolbox and press F1.

To draw a freestanding label
1.	Click the Label tool in the toolbox.							
2.	Click where you want to place the label.
3.  Type in your label. As you type, Microsoft Access sizes the label to fit your text. 

To edit text in a label

1.	Click the label attached to a text box.  Microsoft Access selects the label.
2.	Click the label again. Microsoft Access places an insertion point in the text of the label. Now you can edit the text.

Change the Appearance of Text

Visual style in text can add important functional impact or aesthetic appeal to your form.  

To make text  italic

1.	Select the label. When you select a label or a control that includes text, the toolbar enables additional tools for changing the appearance of the text in the Home menu.

2.	Click the Italic button on the toolbar.						

3.  From the popup menu, choose Size, and then choose To Fit. Microsoft Access resizes the label to fit the new text.




To change the visual style of a control

1.  Select the label and use the various options available through the visual style buttons on the Home toolbar.  


Fill/Back Color           Font/Fore Color	Line/Border Color         Special Effects: Flat         Line/Border Width

An example of a customized form is shown in Figure P4-4.
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Figure P4-4:  Customized Form based on Branch table in Form View.


Activity P4-5

Customize your BranchView form to look like the form shown in Figure P4-4. Once you have made the required alterations, save your form as BranchView2.



Now continue to experiment with different fonts, sizes, colours, and alignments for the text.  Use the buttons on the toolbar or the options in the palette to make your changes. If you want to save this version of your form, use the File menu and choose Save As to give this form another name, otherwise, close the form without saving.
 

Display Values using a Combo Box

The controls that you use to enter, update, and display data from a table or query are bound to fields in the table or query. 

For some controls it is useful to use a combo box that shows appropriate values for the control and if necessary the values can be displayed with  descriptive text that informs the user  about the different values. The user simply makes a selection from a list of possible entries. This helps the user to enter the correct values for a given control.  You can replace a control with a combo box by first deleting the control and then using the Combo Box Wizard to create the new combo box control.

To delete a control

1.	Click on the text box to select it.

2.	Press the DEL key. Microsoft Access deletes the text box and its label. Note that to delete a label without deleting the text box, select the label and press the DEL key.

When you add a bound control to a form, your first step is to select the tool from the toolbox for the type of control you want.

To add a combo box control to a form


1.	Click the Combo Box tool in the toolbox.										
2.	Click the form where you want to draw the combo box. Microsoft Access displays the first Combo Box Wizard dialog box.

3.	Follow the instructions in the Control Wizard dialog boxes.

4.	Click the Finish button to create the combo box control.

Switch to Form view to see the combo box control. 

If you selected to type in the values to be displayed by the combo box, you must now defined these values using the property sheet for the combo box, which is described in the following section.

Set Control, Section, or Form Properties

Each control on a form has a set of properties.  Properties determine a control’s appearance and behaviour.  For example, when you give your freestanding label, italic lettering and a three-dimensional look, you were setting properties for the label.  To see and set control properties, you open the property sheet.  The property sheet shows the properties of the selected object. A form and each of the sections and controls it contains has its own set of properties. 

To display the property sheet

From the popmenu menu, choose Properties (or click the Properties      button on the toolbar). 

To see the properties of an object

With the property sheet open, click on a control. Microsoft Access displays the properties of the selected control in the property sheet.  You can leave the property sheet open while you work on your form.

Display a Description in the Status Bar

In Form view, the status bar displays the descriptions you entered for each field when you originally create a table.  Because the combo box is a new control, it does not have a description to display.  You can define a description by setting the Status Bar Text property for the combo box. We noted earlier that, when the combo box is created, the Combo Box Wizard sets the properties of the new control.

The Row Source Type property tells Microsoft Access what type of source provides the values in the list: a table or query, a list of values you provide, or a list of fields.

The Row Source property identifies the source of the list.  For example, if the Row  Source Type property is set to Table/Query, you set the Row Source property to the name of the table or query that contains the values for the list.

The Column Count property determines how many columns are in the combo box.

The Column Widths property determines the width of the columns.

To set the Row Source property

1.	While viewing the properties of the control, select the Row Source property box.
2.  In the Row Source property box, type in the source of the values, e.g. table name, query name or enter a list of values, where each value is separated  by a semi-colon.

To set the Status Bar Text property

1. While viewing the properties of the control, select the Status Bar Text property box.
2.  In the Status Bar Text property box, type in the description. 


Make Your Form Work for You

When you create a form that you or someone else will use to add, change, or view records, think about how you might want that form to work for you.  For example, to automatically enter new values for each new record, to display error messages, or to show the results of calculations in some controls.

Setting a Default Value

In some cases, one value might show up in a field more often than any other.  For example, we may assume that ‘SINGLE’ is the most common property type in the company. When you add a new property, you can have Microsoft Access automatically fill in the type field with ‘SINGLE’.  We set the Default Value property for the control to ‘SINGLE’. You can also set the Default value of a field when you design your table.  Then Microsoft Access will automatically apply that value to any control you create that is bound to the field.

Showing Calculations

A control that is bound to a field in a table or query displays data from the field.  You can also use a control to display data that is not in your tables.  For example, you might want to display the current date in a text box on the BranchView form.  The text box would not be bound to any field; instead, it would display the result of this expression:  =Date().  The Date function returns the current date as reported by the system clock in your computer.  A control that displays the result of an expression is called a calculated control.

To create a calculated control, select the tool in the toolbox for the control you want, and then click your form where you want the control to appear.  Microsoft Access creates the unbound control.  Now type the expression that you want in the control, or set the control’s Control Source property to the expression.

Creating Validation Rules

Validation rules help you ensure that information entered into a form is correct before Microsoft Access stores it in your tables.  For example, a video shop opened on 1st September 1985 and therefore the dateJoined field for its Member table cannot take a value that is before this date. If we attempt to enter a date that is wrong, we want  Microsoft Access to stop errors like this and display a message that helps the user fix the problem.  Just as you use expressions to show calculations on a form, you can also use expressions to set rules for validating data. To create the rule, set the Validation Rule property of the dateJoined  control to the following expression: >=#1/09/85#.

Set the Validation Text  property to a message that you want Microsoft Access to display if the date entered in the text box falls out with the defined range.

You can also set a validation rule for a field when you design your table. Then Microsoft  Access will apply that validation rule automatically to any control you create that is bound to the field.  If necessary, you can set a separate, more restrictive validation rule for that control on the form.
[bookmark: _GoBack]
Activity P4-6

Set a default value for the position controls of your BranchView form. Assume that the majority of staff at branches are of assistant position. 

Add a control to this form to display today’s date in the top-right hand corner.

Set a validation rule for the staffNo control such that no value entered into this field can be less than “S0000”. Also add appropriate validation text. 

Now, save your form and look at it in Form view. Add a new record to your Staff table using your form. 
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